Potentially Critical Security Vulnerability
16 March 2012

A potential security vulnerability has been discovered in the Windows version of Bitcoin-Qt. If you are running Bitcoin-Qt versions 0.5 through 0.6 on Windows you should shut it down and upgrade to either version 0.5.3.1 or 0.6rc4 NOW.

The command-line bitcoin daemon (bitcoind), Mac and Linux versions of Bitcoin-Qt, and versions prior to 0.5 are not affected.

Due to the nature of the vulnerability, we believe it would be very difficult for an attacker to do anything more than crash the Bitcoin-Qt process. However, because there is a possibility of such a crash causing remote code execution we consider this a critical issue.

If you have any questions, feel free to drop by the #bitcoin-dev channel on Freenode IRC.

You can download updated binaries from SourceForge:
0.6 Release Candidates
0.5.3.1 for Windows and 0.5.3 for Linux

Español: Vulnerabilidad de seguridad (potencialmente crítica)

Una vulnerabilidad de seguridad posible no son afectadas en la versión Windows de Bitcoin-Qt. Si está utilizando Bitcoin-Qt 0.5 a través de las versiones 0.6 en Windows, debe cerrar y actualizar a la versión 0.5.3.1 o 0.6rc4 AHORA.

El daemon de la línea de comandos (bitcoind), las versiones Mac y Linux de Bitcoin-Qt, y las versiones anteriores a 0.5 no son afectadas.

Debido a la naturaleza de la vulnerabilidad, creemos que sería muy difícil para un atacante para hacer algo más que chocar Bitcoin-Qt. Sin embargo, debido a que existe la posibilidad causaría la ejecución remota de código consideramos este un tema crítico.

Si tiene alguna pregunta, venga al canal #bitcoin-dev en Freenode.

Puede descargar los archivos binarios actualizados desde SourceForge:
0.6rc
0.5.3.1 para Windows y 0.5.3 para Linux

Deutsch: DRINGEND: Windows Bitcoin-Qt update

Es wurde eine potenzielle Schwachstelle in der Windowsversion Qt-Bitcoin entdeckt. Wenn Sie mit Bitcoin-Qt-Versionen 0.5 bis 0.6 unter Windows arbeiten, sollten Sie das Programm beenden und ein Upgrade auf entweder Version 0.5.3.1 oder 0.6rc4 JETZT durchführen.

Der Kommandozeilen-Bitcoin Daemon (bitcoind), Mac-und Linux-Versionen Bitcoin-Qt-Versionen vor und 0.5 sind nicht betroffen.

Aufgrund der Art der Schwachstelle glauben wir, das es sehr schwer wäre mehr als einen Absturz des Bitcoin-Qt Prozesses zu bewirken. Nachdem jedoch eine theoretische Möglichkeit eine "Remote Code Execution" besteht erachten wir das als einen kritischen Fall.

Wenn Sie noch Fragen haben, kommen sie in #bitcoin-dev Kanal auf FreeNode IRC.

Binärdateien sind auf SourceForge verfügbar:
0.6 Release Candidates
0.5.3.1 für Windows und 0.5.3 für Linux

Nederlands: Mogelijk kritisch veiligheidsprobleem

Er is een een mogelijk veiligheidsprobleem gevonden in de Windows versie van Bitcoin-Qt. Als u Bitcoin-Qt versie 0.5 tot 0.6 draait, sluit het dan af en upgrade naar versie 0.5.3.1 of 0.6rc4 NU.

De commandolijn bitcoin daemon (bitcoind), en de Mac of de Linux versie van Bitcoin-Qt en versie voor 0.5 zijn niet kwetsbaar.

Omwille van het soort veiligheidsprobleem geloven wij dat het zeer moeilijk zou zijn voor een aanvaller om iets anders te doen dan het Bitcoin-Qt proces te doen crashen. Echter, aangezien er een mogelijkheid is tot het uitvoering van code, beschouwen we dit als een kritisch probleem.

Indien u enige vragen heeft, kom gerust langs op het het #bitcoin-dev kanaal op Freenode IRC.

U kan een aangepaste versie downloaden op SourceForge:
0.6 Release Candidates
0.5.3.1 voor Windows en 0.5.3 for Linux

Русский: Найдена потенциальная критическая уязвимость в версиях Bitcoin-Qt от 0.5 до 0.6 для Windows

Найдена потенциальная критическая уязвимость в версиях Bitcoin-Qt от 0.5 до 0.6 для Windows. Если вы используете одну из этих версий, отключите её и обновитесь до 0.5.3.1 или 0.6rc4 немедленно.

Версия для командной строки, версии до 0.5, а также версии для Linux и MacOS не подвержены этой уязвимости.

Из-за сути проблемы мы считаем что злоумышленнику будет сложно сделать что-либо помимо завершения процесса Bitcoin-Qt с ошибкой, но поскольку есть теоретическая вероятность что это может вызвать удалённое выполнение кода, мы считаем эту уязвимость критической.

Если у вас есть какие-либо вопросы, обращайтесь на канал #bitcoin-dev сети Freenode.

Вы можете скачать обновлённые выполняемые файлы с SourceForge:
0.6 RC
0.5.3.1

Italiano: Potenziale vulnerabilità di sicurezza critica.

Una potenziale vulnerabilità di sicurezza è stata scoperta nella versione di Windows di Bitcoin-Qt. Se stai usando Bitcoin-Qt su Windows dalle versioni 0.5 alla 0.6 dovresti chiuderla e aggiornarla alle versioni 0.5.3.1 o 0.6rc4 ORA.

La versione di Bitcoin a linea di comando (bitcoind), le versioni Mac e Linux di Bitcoin-Qt, e le versioni precedenti alla 0.5 non sono affette dal problema.

Vista la natura della vulnerabilità, crediamo sia molto difficile che un attacco posso fare niente di più del crashare il processo Bitcoin-Qt. Tutta via, visto che c'è la possibilità che questo crash possa causare l'esecuzione di codice remoto lo consideriamo come critico.

Per qualunque domanda, sentitevi liberi di venire sul canale #bitcoin-dev su Freenode IRC.

Potete scaricare le versioni aggiornate da SourceForge:
0.6 Release Candidate
0.5.3.2 per Windows e 0.5.3 per Linux

Português: Vulnerabilidade de segurança potencialmente crítica

Uma vulnerabilidade de segurança em potencial foi descoberto na versão do Bitcoin-Qt para Windows. Se você estiver executando alguma versão entre a 0.5 até a 0.6 do Bitcoin-Qt no Windows, você deve desligá-lo e atualizá-lo para a versão 0.5.3.1 ou 0.6rc4 AGORA!

A versão em linha de comando do Bitcoin (bitcoin daemon - bitcoind), as versões para Mac e Linux do Bitcoin-Qt, e versões anteriores a 0.5 não são afetadas.

Devido à natureza da vulnerabilidade, acreditamos que seria muito difícil para um atacante conseguir fazer qualquer coisa além de travar o programa Bitcoin-Qt. No entanto, como há uma possibilidade de tal acidente causar uma execução de código remota, nós consideramos esta uma questão crucial.

Se você tem qualquer questionamento, sinta-se livre para entrar no canal #bitcoin-dev no servidor IRC em Freenode.

Você poderá instalar os novos binários a partir do SourceForge:
0.6 Release Candidates
0.5.3.1 para Windows e 0.5.3 para Linux

Traduzido por Thiago Martins (ThiagoCMC)

Polski: Potencjalnie Krytyczne Zagrozenie Bezpieczenstwa

Potencjalne zagrozenie zostalo odkryte w Bitcoin-QT wersji Windows. Jesli masz uruchomiony Bitcoin-Qt w wersjach 0.5 przez 0.6 w wersji Windows powinienes je zamknac i pobrac najnowsze wersje 0.5.3.1 lub 0.6rc4 TERAZ.

Demon bitcoin z linni polecen(bitcoind), wersje MAC i Linux Bitcoin-QT, i wersje ponizej 0.5 nie sa zagrozone.

Z wzgeldu na nature zagrozenia, wierzymy ze osoba atakujaca miala by spory problem z zrobieniem czego kolwiek innego niz zawieszenie procesu Bitcoin-QT. Jednak, jest mozliwosc ze takie zawieszenie procesu moglo by doprowadzic do zdalenego odpalenia kodu uwazamy je za krytyczne.

Jesli masz jakie kolwiek pytania kieruj je na kanal #bitcoin-dev IRC Freenode.

Mozesz sciagnac zrodlo z SourceForge:
0.6 Release Candidates
0.5.3.1 dla WIndows i 0.5.3 dla Linuxa

Български език: Уязвимост в сигурността.

Уязвимост в сигурността бе открита при Windows версията на Bitcoin-Qt.Ако използвате Bitcoin-Qt версия 0.5 до 0.6 през Windows,ще се наложи да я спрете и да направите ъпгрейд до 0.5.3.1 или 0.rc4.Command-line даемон-а(bitcoind),няма да бъде афектиран за потребители на Mac или Linux.Поради вида на тази уязвимост,ние вярваме,че би могло да бъде доста трудно за атакуващия да направи нещо повече от това да crash-не процесът - Bitcoin-Qt.Поради това ние го считаме за критичен проблем.

Ако имате някъкви въпроси,не се притеснявайте да ги зададете в #Bitcoin-dev @freenode.

Можете да изтеглите ъпдейтите от Sourceforge:
0.6 Release Candidates
0.5.3.1 за Windows и 0.5.3 за Linux.

Ελληνικά: Σοβαρό πρόβλημα ασφάλειας

Ένα πιθανά σοβαρό πρόβλημα ασφάλειας εντοπίστηκε στην έκδοση Windows του Bitcoin-Qt. Εαν χρησιμοποιείτε Bitcoin-Qt εκδόσεις 0.5 έως 0.6 στα Windows, αναβαθμήστε άμεσα σε έκδοση 0.5.3.1 ή 0.6rc4.

Ο δαίμονας bitcoind, οι εκδόσεις Mac, Linux του bitcoin-Qt, και εκδόσεις παλαιότερες της 0.5 δεν επηρεάζονται απο το πρόβλημα.

Λόγω της φύσης του προβλήματος, πιστεύουμε οτι είναι σχεδόν απίθανο κάποιος εισβολέας να καταφέρει οτιδήποτε περισσότερο απο το να κλείσει το Bitcoin-Qt. Παρ'όλα αυτά, επειδή κάτι τέτοιο θα μπορούσε να οδηγήσει σε απομακρυσμένη εκτέλεση κώδικα, θεωρούμε το συγκεκριμένο πρόβλημα πολύ σοβαρό.

Για οποιαδήποτε απορία μπορείτε να επισκευθείτε το κανάλι #bitcoin-dev στο IRC (Freenode).

Μπορείτε να κατεβάσετε νέες εκδόσεις απο το SourceForge:
0.6 Release Candidates
0.5.3.1 για Windows και 0.5.3 για Linux

Svenska: Potentiellt kritiskt säkerhetshål

Ett potentiellt kritiskt säkerhetshål har upptäckts i Windowsversionen av Bitcoin-QT. Om du kör Bitcoin-QT i någon av versionerna 0.5 t.o.m. 0.6 för Windows så bör du stänga av programmet och uppgradera till version 0.5.3.1 eller 0.6rc4 OMGÅENDE.

Kommandoradsprogrammet Bitcoin daemon (bitcoind), Mac- och Linuxversionerna av Bitcoin-QT samt tidigare versioner än 0.5 påverkas ej.

P.g.a. den typ av sårbarhet det handlar om tror vi att det skulle vara mycket svårt för en angripare att göra något att än att krascha Bitcoin-QT-processen, men eftersom det finns en risk att en sådan krasch kan orsaka "remote code execution" betraktar vi detta som ett kritiskt säkerhetshål.

Om du har några frågor är du välkommen in på kanalen #bitcoin-dev på Freenode IRC.

Du kan ladda ner uppdaterade binärer från SourceForge:
0.6 Release Candidates
0.5.3.1 för Windows och 0.5.3 för Linux

This notice last updated: Fri, 16 Mar 2012 22:58:00 UTC
Go back to the network alerts history
A community website sponsored by Foundation The Bitcoin Foundation